Rome Total War: Barbarian Invasion - The Iberian Conflict Client Patch v1.0 - v1.1

Rate

Total votes: 18
20

This patch will bring your TIC installation from v1.0 to v1.1. You MUST have The Iberian Conflict v1.0 (the Iberian conquest) already installed.

Add new comment

CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions.

Add new comment